Version History

From FACET3D
Jump to: navigation, search

Version 16.5.13 Released on 5/13/2016

  • PHAST 7.x import corrected jet fire duration value (5/12/2016
  • Added modeled fire MaximizeGroundViewFactor option (5/5/2016)
  • Updated fileformat version id to 25: variable ACH, coord system, zone2 (5/4/2016)
  • Added Zone 2 rendering (5/4/2016)
  • Added functionality in PHAST 7.x importer to skip scenarios with skip in their name or path (4/8/2016
  • Corrected problem with error handling for importing incomplete of failed fire results from PHAST 7.x (4/8/2016
  • Repaired exception handling for scenarios that completed with errors in PHAST 7.x (4/8/2016
  • Added error handling for params.xml defaults parsing (4/8/2016
  • Set toxic averaging time to 600 sec in PHAST 7.x (4/8/2016
  • Addressed dispersions imported from PHAST 7.x not defaulting to max LFL time (4/7/2016
  • Fixed space handling in scenario and weather names in PHAST 7.x (4/7/2016
  • Fixed modeled fire import error in PHAST 7.x (4/7/2016
  • Added wind dependent ACH via linear relationship (4/4/2016)
  • Added geographic and projection coordinate systems (3/30/2016)
  • Fixed bug where modeled fires on unstructured grids did not use their duration to limit dose (3/15/2016)
  • Fixed modeled fire flame impingement freq plot by adding angle fraction of fire (2/24/2016)
  • Added modeled fire angle quick change via runsub 5
  • Added camera near and far clip distances to program settings (2/24/2016)
  • Changed Spouge frequency data to be full leak only (2/19/2016)
  • Changed building move command and added resize command (2/17/2016)
  • Added Spouge frequency data to library and made DNV data full leak only (2/17/2016)
  • Fixed bug with line locations and building screening report (2/17/2016)

Version 16.2.1 Released on 2/1/2016

  • Fixed bug with region indoor building vulnerability (1/29/2016)

Version 16.1.27 Released on 1/27/2016

  • Updated fileformat version id to 24: independent mesh control properties (1/26/2016)
  • Added more render properties to independent mesh controls (1/26/2016)
  • Added mesh import to fire triangles form (1/25/2015)
  • Fixed bug with QRA precalc fires not at 0 deg (1/13/2016)
  • Fixed bug with QRA toxic evac for angle ranges that pass through 0 deg (1/13/2016)
  • Updated fileformat version id to 23: new aggregate risk occupancy data storage (1/13/2016)
  • Added region aggregate risk (1/13/2016)
  • Changed aggregate risk inputs and calculations (1/8/2015)
  • Added PHAST v7.x import BETA (1/5/2015)
  • Changed group threat color to propagate to children (1/5/2016)
  • Fixed bug with FN curve by removing items during cumulation (1/5/2016)
  • Added FN plot integration to risk report (1/5/2016)
  • Added rainout contour to dxf export (1/5/2016)
  • Changed threat create name for line threats (1/5/2016)
  • Changed QRA building toxic dose calcs to use variable integration step for a 10x speedup (12/4/2015)
  • Changed Delunay meshing to allow orphan verticies (12/8/2015)
  • Changed CreateThreats setting CongBlockCombineMethod=TwentyPercentRuleStepFunc as default (12/8/2015)
  • Changed CreateThreats setting FitCloudsOnlyByHeight=True as default (12/8/2015)
  • Added hit detection for modeled fires on shift+click (12/2/2015)
  • Added better formatting of independent grid controls (12/2/2015)
  • Fixed crash upon import of CFD data related to derived variables calc (12/2/2015)
  • Added UDC file data validation to check for unknown buildings or sources (12/2/2015)
  • Objects form filter will persist after from close (12/2/2015)

Version 15.12.1 Released on 12/1/2015

  • Fixed a bug in grouped threat filter (12/1/2015)
  • Added base grid saving (12/1/2015)
  • Updated fileformat version id to 22: saved base grids (12/1/2015)

Version 15.11.23 Released on 11/23/2015

  • Added CloudArrivalTime method (11/23/2015)
  • Added ContourGridResultDisplay program setting (11/23/2015)
  • Changed create threats from to show toxics (11/23/2015)
  • Added better names for confinement in reports (11/11/2015)
  • Restored dispersion side view plot bottom line (11/11/2015)
  • Added warning for incomplete toxic Or flammable chemicals (11/11/2015)
  • Added warning for contour grid pressure type reflected (11/11/2015)
  • Added correction for GW And CW for buildings without windows (11/11/2015)
  • Fixed bug with surface pick near vertex returning wrong vertex (11/11/2015)
  • Added DXF export surface colors when in postproc (11/11/2015)
  • Added incident building warnings to reports (11/11/2015)
  • Changed some threat report significant digits (11/11/2015)
  • Added new string filter boolean operations for listviews (11/11/2015)
  • Fixed bug with userdefined threat angles (11/11/2015)
  • Added filter to listviews with boolean operations (10/24/2015)
  • Changed create threats settings to be in separate form and not program settings (9/30/2015)
  • Added Detonate Cloud if CB DDTs create threats setting (9/30/2015)
  • Added window and door PIs to pireplace commandline command (9/29/2015)
  • Added building stack height and shutoff conc for QRA shelter in place (9/25/2015)
  • Updated fileformat version id to 21: user threat application angles (9/25/2015)
  • Added user threat application angles (9/25/2015
  • Added calculation of damage after FLACS import of pressure Or impulse (9/18/2015)
  • Added store And retrieve options to basegrid command (9/18/2015)
  • Added validation warnings for damage ground contour levels that don't match PI curves (9/18/2015)
  • Added dispersion plot legends (9/17/2015)
  • Fixed dispersion type none plot bug (9/17/2015)
  • Added glass width > 0 and window count = 0 validation rule (9/17/2015)
  • Added BDL Version 2 and BST CoOp threats validation rule (9/17/2015)
  • Changed toxic dispersion that does not reach ERPG-3 validation rule to an error (9/17/2015)
  • Changed user defined consequence file lines starting with # to be ignored (9/17/2015)
  • Changed Zone 1 calculation to ignore threats with SL <= 1.7 and FS <= 0.092 (9/17/2015)
  • Added ContourGridPressureType program setting to allow for reflected load on ground (useful for applied damage PI) (9/17/2015)
  • Added ReportViewed program setting to allow for direct Excel reports (9/17/2015)
  • Fixed bug related to flame imp. and rainout rendering after importing CFD fire results (9/17/2015)
  • Added KFX import features to cfd m and cfd c commands (8/6/2015)
  • Fixed transparency bug on overlapping textures (7/30/2015)
  • Added Building Fire Scenarios report (7/10/2015)
  • Added building vulnerability report (6/22/2015)
  • Changed scale commandline command to also operate on buildings (6/4/2015)
  • Fixed FLACS import (rs 30) scale factor bug (6/3/2015)
  • Building outdoor conc. to get internal explosion now includes dispersion duration (5/13/2015)
  • Added flammable worst case time option for flamm. conc. calculations (5/13/2015)
  • Updated fileformat version id to 20: modeled fire triangles (2/5/2015)
  • Added modeledfire freeform triangles input (2/5/2015)
  • Added LMB and RMB building move and resize actions for selected buildings (12/8/2014)
  • Added more decimal places to VBR and AvgDia in threat form (11/13/2014)
  • Fixed append threats chemical case sensitive bug (11/13/2014)
  • Updated CreateThreats to include energy reduction when overriding a threat due to non-homogeneous congestion (11/13/2014)
  • Added ABS standard library building components to library (11/13/2014)
  • Changed mixed mode Triangle.Managed.dll to fully managed Triangle.dll (9/4/2014)
  • Added weather dependency to multiple models (VCE, BLEVE, PVB, Radiation, Chemicals) (9/4/2014)
  • Changed SaveAs to copy texture images to new location (8/1/2014)
  • Added multiple congestion block combine algorithms (7/22/2014)
  • Fixed bug in create threats autorotate w/ ignition sources from 3/24/14 (7/22/2014)
  • Added max LFL, max VOl, and max AREA to dispersion report (7/11/2014)
  • Added Tecplot export (7/11/2014)
  • Added toxic worst case evacuation time checkbox (6/2/2014)
  • Updated fileformat version id to 19: flamdisp SIP type, PVB, BLEVE (5/30/2014)
  • Changed PVB and BLEVE models to use latest shape factors (5/30/2014)
  • Changed BLEVE model to use Baker-Tang curves (5/30/2014)
  • Changed flash fire QRA to allow flammable dispersion SIP (5/27/2014)
  • Changed predefined jet fires to use Z coord to adjust flame impingement distance for grade (5/21/2014)
  • Added flame impingement, pool rainout, and zone 1 show in legend checkboxes (4/29/2014)
  • Changed modeled fire precalc code to be more robust and faster (4/28/2014)
  • Added UserDefinedConsequenceClass for overwriting QRA results during analysis (4/21/2014)
  • Fixed saving paths for duplicate thermal dose values (4/16/2014)
  • Changed path finding to apply dose multiplier > 1 to dose returned (4/16/2014)
  • Updated fileformat version id to 18: region lines offset, disp rendering options, label arrow, clipping planes, link enabled (3/26/2014)
  • Added Chemical form list view column sort (3/26/2014)
  • Changed PHAST import to not overwrite line and poly locations, only point locations (3/25/2014)
  • Added lines offset property to regions with trim options under rendering (3/24/2014)
  • Changed to separate installs for 32 and 64 bit versions; all dlls and exe signed also (3/24/2014)
  • Added flacs option to vapor cloud create threats command options; reads NFMOLE files (3/24/2014)
  • Added ProgSetting to use mass instead of volume when calculating energy during threat creation (3/4/2014)
  • Added more dispersion rendering flammable concentrations (HalfLFL and Stoic) (3/4/2014)
  • Fixed a bug reassociated chemicals that are also part of a mixture (2/4/2014)
  • Added Selected Object Color option (1/29/2014)
  • Added Translucent Surfaces Reduce Radiation option (1/29/2014)

BETA Version 13.12.20 Released on 12/20/2013

  • Fixed bug with door location units inched to feet (12/19/2013)
  • Changed toxic disperisons to include Pign to be consistent with flammable dispersions (12/18/2013)
  • Fixed a bug where building flammable and building toxic QRA calcs were adding 1/wind_directions to freq (12/18/2013)
  • Fixed a bug where flammable dispersion flash fire on buildings was not applying Pign (12/18/2013)
  • Added PIREPLACE commandline command for using 1 PI to replace many other (11/11/2013)
  • Fixed bug with PHAST import of discharge results for catastrophic rupture cases (11/6/13)
  • Changed truncated modeled fire SEP increase to have an upper bound of 400 kW/m2 (10/27/2013)
  • Added transparent surface radiation reduction to occlusion feature for modeled fires (10/18/2013)
  • Fixed a bug with toxic stationary dose/lethality not using stationary time correctly (10/3/2013)
  • Added DNV leak frequency database (10/2/2013)

BETA Version 13.9.27 Released on 9/27/2013

  • Fixed a bug in reports using combine by prefix option (9/27/2013)
  • Fixed a bug in PHAST import of discharge results for "skip" items (9/16/2013)

BETA Version 13.7.12 Released on 7/12/2013

  • Fixed a bug where toxic max concentration avg. time was not set to 60 min for a ERPG transform (7/12/2013)
  • Added arrow marker type to labels (7/9/2013)
  • Fixed the window and door Z coordinate calculation (7/9/2013)
  • Modified the chemical reassociate button to work on more than 1 chemical at once (7/9/2013)
  • Added more building and threat listview columns that are hidden by default (7/9/2013)
  • Added license file restrictions for select features (7/9/2013)
  • Added multi-object editor to main objects listview (7/2/2013)
  • Added transformation matrix builder to CFD contours importer
  • Added filter and select columns to main object list view (6/17/2013)
  • Added Building internal explosion LFL fraction to file options (5/30/2013)
  • Added Unique Ids Report (5/29/2013)
  • Added DrawCircle and DrawLine commandline commands (5/24/2013)
  • Modified Phast import to skip new chemicals with no references (5/24/2013)
  • Added Base Plane Textures form (5/23/2013)
  • Fixed bug where freq. link dispersion could no be reset after dispersion was deleted (5/23/2013)
  • Fixed bug with exceedance curves using group frequency which did not match exceedance contours
  • Added CongestionBlock2Dto3D program settings option (5/14/2013)
  • Added IncreaseTruncatedModeledFireSEP option (5/14/2013)
  • Fixed ViableDoors implementation for fire and toxic QRA calcs (5/14/2013)
  • Fixed modeled fire path find evac dose calc for building shadows (5/14/2013)
  • Fixed objects listview item focused bug; arrow key navigation now works after dialog return (5/10/2013)
  • Added Outdoor LFL frac vs. ACH relation for SIP building internal explosion
  • Added prevent energy reduction checkbox to dispersion threat creator form
  • Added ACH to 1E6 for QRA toxic shelter based on BDL and building type or door/window exceedance pressure
  • Added ViableDoors method for QRA toxic and fire evac calcs; viable if exceedance pressure not reached
  • Added HasLargeOpenings field to building form; QRA will set flash fire lethality to 1 if bldg is inside LFL
  • Fixed bug where adding and then removing a consequence event to a scenario would corrupt file (4/28/2013)
  • Fixed a graphics caching bug for transparent surfaces (4/24/2013)

BETA Version 13.4.23 Released on 4/23/2013

  • Fixed a caching bug related to showing result subsets (F4) and getting no results (4/23/2013)
  • Updated buildings and unstructured mesh controls outside domain to be skipped or clipped (4/23/2013)
  • Fixed bug with unstructured grid not clearing results fully between runs (4/23/2013)
  • Added clipping planes (4/16/2013)
  • Added window and door copy button to building form (4/8/2013)
  • Added all BeastV3 buildings and components to library (4/5/2013)
  • Fixed bug with appendfile command and QRA files
  • Added Scenarios Summary report (4/2/2013)
  • Fixed bug in screening report where grouped sources would apply min/max limiter (error) in addition to XY locations (3/29/2013)
  • Modified reporting combine by prefix character to be user defined in program settings
  • Changed building IR occupancy to allow multiple cases (3/29/2013)
  • Changed IR calculations to be superposition regardless of grouping; significant speedup and data set size reduction (3/25/2013)
  • Added command line shift+enter option to accept all forthcoming command defaults without prompt
  • Added create threats option to prevent CB combining across region lines
  • Modified bld command to accept wildcards for modified building name (3/11/2013)
  • Modified QRA toxic contour creation achieving 7x speedup (3/7/2013)
  1. no cross section overlap assumed during evacuation dose precalculations
  2. monotonically decreasing option for toxics now only for consequence mode
  • Fixed bug with wind rose data where update of underlying data was not done until restart (3/7/2013)
  • Added Set Active Time to dispersion list view quick links (3/4/2013)
  • Added Time at MaxLFL and Time at Max Vol to Dispersion Report (3/4/2013)
  • Added Time field to Dispersion Threat Creator Form (3/4/2013)
  • Added POLYGON keyword to scenarios notes PHAST import for pool fire bund
  • Added additional region listview columns
  • Added flammable volume to dispersion report (2/22/2013)
  • Modified the active flamm. time to not exceed the source duration (max of all seg.time+seg.duration) which prevents detached clouds (2/19/2013)
  • Modified the flammable conc. contour grid calculation to be independent of active flammable time (2/19/2013)
  • Modified Shift+Click to sort results on value in message window
  • Added exclude token '--' for use in multiselect forms (2/14/2013)
  • Added LinkEnabled property to Threat freq. link (2/11/2013)
  • Fixed autogroup button to ignore dia2 for cumulative freq. type (2/8/2013)
  • Fixed bug with freq. link saving from HD, UDT, PVB, and BLEVE threats (2/5/2013)
  • Added fireball import from PHAST (catastrophic leak model only) (2/1/2013)
  • Fixed bug with toxic dispersion stationary dose for points beyond the last crosssection x value (2/1/2013)
  • Added Modify Concentration action to dispersion form next to Import and Export (1/31/2013)
  • Added duration to dispersion list view (01/31/2012)

BETA Version 13.1.30 Released on 1/30/2013

  • Fixed bug related to flame impingement contour rendering under Individual Risk variable (01/30/2012)
  • Fixed bug where cached Phast import disp/fire locations were receiving multiple unit conversions (01/30/2012)
  • Added 'Copy Selected Text' command to message area context menu (01/29/2012)
  • Added DXF import all objects to existing mesh option (01/29/2012)
  • Dispersions with invalid calctype will show as red in listview (01/29/2012)
  • Added Dispersion set calculation type combobox to Phast import form (01/29/2012)
  • Phast import AutoSetup now only does scenarios that were created/modified rather than the entire collection (01/29/2012)
  • Updated Scenario Copy to propagate to consequence events (01/28/2013)
  • Added update of non-overridden threats (energy, sl, fs) when chemical properties change (lbv, dHc) (01/25/2013)

BETA Version 13.1.24 Released on 1/24/2013

  • Fixed bug introduced after version 12.5.8 regarding chemical mixtures with inerts and LeChateliers mixing rule for LFL, UFL, LBV properties (01/24/2013)

BETA Version 13.1.23 Released on 1/23/2013

  • Added Building Shelter Report which gives the time varying indoor conc, dose, and lethality for 1 building and 1 dispersion.
  • Updated fileformat version id to 17: toxic equiv. conc and ref. time options; toxic conc. transform option (1/16/2013)
  • Added Chemical Other15, Other30, Other60 user defined concentrations; added toxic conc. transform option
  • Changed toxic equiv. erpg to just toxic equiv. conc option and added a reference time option
  • Added Run AutoSetup on All Scenarios checkbox to phast import options
  • Added AutoSetup button to scenario form to set freq. type, diameters, and groupID based on hole sizes found in consequence event names (XXXmm)
  • Changed program setting CombineThreatResultsByScenario to CombineResultsByCommonPrefix and added effect to BuildingScreeningReport
  • Fixed arc rotation in meshes
  • Added Hydrogen to saturated chemicals database
  • Changed DrawBuilding command to Building command with more options (Add, Modify, Delete)
  • Added scenario frequency data indicator to listview
  • Added scenario deletion optionally propagates to dispersions and fires
  • Added jet fire leak rate import from PHAST
  • Added caching to PHAST importer; multiple imports of same file will not have to reparse
  • Fixed BST threat create bug related to 20% rule and interpolation decimal places
  • Fixed race condition on solver output feedback richtext control
  • Fixed Assembly.LoadFrom bug for x86/x64 dll files on select machines
  • Updated SmartPropertyGrid control to version 3.3; fixes .NET 4.5 (Windows 8) bug

BETA Version 12.12.4 Released on 12/4/2012

  • Updated fileformat version id to 16: API 753 zone options, JPF leak rate and ign. prob., bldg windows HAF
  • Added API 753 Zone 1 render option
  • Added risk and exceedance curve reports
  • Added LeakRate and IgnitionProbability to JetPoolFire object
  • Added HeightAboveFloor to building windows
  • Added wind rose plot

BETA Version 12.9.27 Released on 9/27/2012

  • Added options Render North Arrow (valid in 2D orthographic mode only)
  • Added crosswind evac running direction program setting
  • Changed default toxic crosswind evacuation to be from CL to edge instead of edge to edge
  • Changed via split ThermalLethality variable into FlashFireLethality, JetFireLethality, and PoolFireLethality variables
  • Added AnalysisType (Consequence or QRA) to Options->Analysis
  • Updated a major change to how risk results are calculated; added consequence event grouping in scenarios
  • Added dispersion DXF export for outline and solid rendering, added region DXF exporting for line rendering
  • Updated fileformat version id to 15: contour stippling and building windows/doors
  • Added discrete window and door surfaces with PI curves to predefined buildings
  • Updated PHAST import to ignore items with the word "skip" in the title

BETA Version 12.8.6 Released on 8/6/2012

  • Added contour line stippling to ground contours, dispersions, flame impingement, rainout, and meshes
  • Fixed a bug with detailed report (Shift+Ctrl+LMB) where freq. values were being reported as grid values
  • Fixed bug with polygon predefined fire locations for flame impingement and lethality - added IsPointInPredefinedFire function

BETA Version 12.6.29 Released on 6/29/2012

  • Fixed IsPointInModeledFire function (incorrect Continue For and CrossSectionsNormal needed Clamp 0)
  • Fixed UsePrecalcdRadiationCurvesForModeledFires implementation (FireCenter.ToVector2 enforced)
  • Fixed ViewFactorMaxErrorPercent bug in modeled fire radiation solver
  • Updated fileformat version id to 14: dispersion object leak rate
  • Added dispersion object leak rate and UKOAA ignition model option to PHAST import
  • Updated DXF export to be more robust and include dispersion extents and fire impingement
  • Updated via improved Scenario form consequence event adding and editing
  • Added PHAST import scenario name split on backslash

BETA Version 12.6.19 Released on 6/19/2012

  • Added 'Report Loads for Max BDL' program setting (affects wall, roof, and applied loads reports)
  • Updated via significantly increased report generation speed
  • Updated fileformat version id to 13: congestion block and MEM uniformity factor
  • Added MEM obstacle diameter uniformity option to SingleMEM Threat and CongestionBlock objects
  • Added Distance and Area toolbar buttons; enhanced distance and area commandline commands

BETA Version 12.6.6 Released on 6/6/2012

  • Fixed dispersion horizontal width bug
  • Changed out Chemical database for Dippr version; significant change to chemicals
  • Removed ActivateMaterials command. Added PIEnable command.

BETA Version 12.4.20 Released on 4/20/2012

  • Removed line load threat type
  • Added risk calculations
  • Updated contour grid datastore to sqlite db
  • Added new BDL model
  • Added Phast import
  • Added Disperison object. Removed Vapor Cloud object.
  • Combined MeshWeighingControl with IndependentMeshControl in Options.BaseGrid
  • Added Controlling CB Min Volume Fraction option to vapor cloud create threats dialog.
  • Added fire probit values to options for lethality
  • Changed via split toxic variable into toxicconcentration and toxicdose
  • Added variableprofile command-line command.
  • Added pidelete and picopy command-line commands.
  • Added ground contour damage PI curves to legends options
  • Added sorting to main data objects column headers
  • Updated fileformat version id to 12: added vapor cloud location object
  • Added location object to vapor cloud object, replacing position vector3.
  • Updated chemical database name format to now be more liberal, allowing spaces and capitalization.
  • Updated chemical parse error to give more information

Version 11.8.1 Released on 8/1/2011

  • Updated fileformat version id to 11: added variable toxic exposure time, jpf containment, gauge color, gauge scale factor, etc...
  • Updated ubl command to accept S,E,N,W,R or s,e,n,w,r in addition to 0,1,2,3,4 for building faces
  • Updated expression evaluator (Ctrl+LMB on numeric textbox) to more capable version
  • Added CanvasSizeMode to program settings to control size of graphics window
  • Added gauge, label, and ignition source copy method to objects menu
  • Added Delete and Copy keyboard shortcuts to objects menu
  • Object menu items are now focused after an edit such that the arrow keys work appropriately
  • Updated chemical mixture calculations to use formula for parsing atom counts
  • Updated chemical mixture toxic properties to not be defined by mixture mole fractions but rather user defined
  • Updated ground contours UI and added color and enabled properties
  • Added threat color
  • Updated postproc render of fire and toxics to use active threats status
  • Added pool fire containment option for polygon locations
  • Updated all polygon clipping (FI, Rainout) to new clipper library
  • Added reassociate button to chemicals form to change object chemicals links from chem A to B
  • Fixed toggle enabled behavior on group threats form
  • Updated toggle enabled behaviour if no objects selected
  • Added gauge color and scale factor. Added gauge distance (min. to any threat) to gauge report.
  • Updated appendfile command
  • Updated F2 to cycle through view mode 2D rotation options
  • Toxic exposure time for lethality calculation can now be a function of downwind distance
  • Added Subtract VBR from Intersecting Volume option to create threats dialog (MEM only)
  • Updated spreadsheetgear.dll to latest version for >256 columns
  • Added MAX formula to columns in BDL and CDL table
  • Updated render scale bar to auto expand/contract and round value to a nice number
  • Changed extrapolation method for fire curve data from exponential to linear
  • Added detonate entire cloud checkbox to create threats form
  • Added toxic hazards report - indoor duration to a specified lethality using given air changes
  • Added building occupancy, permanence, and shelter type properties to buildings input report
  • Fixed a bug related to building and region shelter type FireAndToxic enumeration
  • Added mesh import rename and merge by color options to import dialog

Version 11.4.12 Released on 4/12/2011

  • Fixed a bug related to gauges during file open
  • Added pool fire rainout rendering options
  • Added cached AABB to HE_face to increase path finding speeds on unstructured 2D grids
  • Added manual vapor cloud create threats commandline switch
  • Updated location editor to open/close on Ctrl+Enter

Version 11.3.25 Released on 3/25/2011

  • Added Vector2 and Vector3 user control to mesh items with custom paste event handling
  • Added vapor cloud cross section to program settings and refined delaunay robust triangulations.
  • Added color, occupancy, and permanence fields to predefined buildings
  • Updated fileformat version id to 10: added notes field to most objects

Version 11.2.3 BETA Released on 2/3/2011

  • Updated fileformat version id to 9: texture origin pixel and crop and options.renderscalebar and cameras
  • Added "create threats for all angles" button to vapor cloud create threats dialog
  • Updated 12 BST low reactivity chemicals to have a LBV of 40 in chemcial database
  • Updated saved cameras to include projection and view mode
  • Added scalebar rendering option
  • Updated building results internal storage to table, added max P,I for max BDL to wall and roof loads table
  • Fixed marching cubes vapor cloud tessellation for elevated clouds
  • Added function parser to numeric text box. Use Ctrl+LMB to activate.
  • Added origin pixel and crop parameters to textures

Version 10.11.18 BETA Released on 11/18/2010

  • Added labels support to properties form
  • Added properties form for real time object manipulation
  • Updated Label dragging (Ctrl+Alt) with RMB will change offset, LMB will change position.
  • Updated all databases to SQLite
  • Added congestion block auto color when white, BST limits (blue to red) are 0 to 0.66, MEM are 0 to 7
  • Added shelter in place field for buildings and regions
  • Added unstructured contour grid option
  • Added feature to screen shot->file to now give an option to write a data file of the current contour grid variable
  • Added locationmaker commandline command
  • Updated fileformat version id to 8: fire and toxic location object
  • Added location object to toxics and jet/pool fires
  • Fixed fire flame impingement rendering such that only active sources are shown
  • Fixed fire E&E report such that duplicate scenarios are no longer generated

Version 10.8.26 Released on 8/26/2010

  • Updated fileformat version id to 7
  • Improved radiation solver with significant speedup of view factor calculations
  • Added duration field to jet/pool fire objects which will limit thermal dose if fire ends before evacuation does
  • Improved modeled jetpool fire, including dose calcs, yaw-pitch option, color, transparency, point in fire fix
  • Fixed bug in pirecalc command so that all damage results are now cleared before the recalc
  • Added more fields to various object list views in main object editor
  • Added 'Active Results Set' menu item
  • Improved analysis run time by using array instead of dictionary for variable storage
  • Improved memory usage by using array instead of dictionary for variable storage
  • Added disable all ground contours option to legends tab
  • Added automatic subdivision of large background images
  • Added program setting to disable caching of render objects
  • Improved memory management of Cralpha, Iralpha, BST, and MEM objects
  • Added chemical selection filter options

Version 10.7.7 BETA Released on 7/7/2010

  • Improved resizing so under OpenGL, F3D can now be used as a sizeable window
  • Added "Show Contours On Doors And Windows" option to Options->Buildings page
  • Added Ignore Lock (Open Read Only) option for opening of locked files
  • Improved redraw speed by factor of 2 for lines, circles, arcs, and text by caching segments
  • Fixed a bug in MeshMultipleThreatsDamageTable report where PI enabled was not respected
  • Improved cfd contour import to allow recursive selection and filters on path name
  • Improved chemical name filter to handle wildcards
  • Improved panel maker for FLACS (runsub 22)
  • Improved label commandline predictive capacity based on last label added/modified
  • Improved alt+tab such that a render will immediately follow switching back to FACET3D
  • Added description property to label object
  • Added region object and region commandline command
  • Added "Sort Selection" button to labels dialog listview
  • Added "Renumber Selection" button to labels and congestion blocks dialog listview
  • Improved notes text on options page will now serialize to xml file using CDATA tag
  • Improved OpenGL render speed; major for circles and arcs, minor for lines and surfaces.
  • Added mutli-threading to contour analysis engine
  • Added volume column to vapor cloud objects list
  • Improved script dialog to better file handling
  • Upgraded to .NET 4.0 and VS 2010
  • Improved numeric text boxes such that Ctrl + double click will allow value manipulation via equation parser
  • Improved import so that layers will be selected if they contain entities and are not off or frozen
  • Improved circle trimming to check for coincident circles
  • Improved layers dialog so selected objects remain selected and visible after task
  • Improved error descriptions in analysis engine

Version 10.3.4 BETA Released on 3/4/2010

  • Added name filter to toggle selection dialog
  • Fixed formatting bugs in Fire E&E report
  • Added label marker options for circle, square, and diamond

Version 10.1.27 BETA Released on 1/27/2010

  • Added toxic option to use log-linear interpolation on data lookups
  • Added rotated 2D view modes and made them persist to file
  • Fixed BST CoOp method 2.5d to take average of 2d and 3d after free venting is applied
  • Added cancel button to import form
  • Added updateContourgrid option to MapCFDLoads command
  • Added line contours alias option
  • Improved Jet/Pool fire phast import to accept any prefix, not just two digit integers
  • Fixed LWPOLYLINE dxf import bug concerning non-zero elevations
  • Removed time averaging from toxic inputs
  • Fixed chemical database to prompt user for missing chemical w/ fuzzy string search
  • Added energy reduction feedback to MEM and BST forms
  • Made command line windows non-modal. Updated chemical db. Fixed VC vol bug.
  • Updated all reports to use spreadsheet output
  • Updated vapor cloud volume calc. to a direct integration method
  • Added and changed menu keyboard shortcuts
  • Changed label drag to Ctrl+Alt+MouseDrag
  • Added Program Settings to data menu
  • Updated gauges to show reflected loads along with side on loads
  • Updated building screening to work with any threat type
  • Added PI validation during import to check for proper point order (CCW)
  • Added CombineTriangles commandline command
  • Added notes input to options dialog
  • Added set calc type label to meshes/buildings panel
  • Added congestion block subdiv size to vapor cloud create threats dialog
  • Threat solver (including pathfinding) is now multi-threaded
  • Updated EandE report to include radiation dose
  • Updated sec and sef commands to include minimum area and maxium AR cutoffs
  • Updated path finding to exclude disabled meshes/threats in domain calcs
  • Changed web update to upgrade in place only files which need it
  • Added view mode 2D and 3D to view menu
  • Added show main legend option to allow main legend, line contours, or both to be shown
  • Added file locking to prevent concurrent file use
  • Added Toxic object and associated options
  • Changed VaporCloud render method to ComboBox in options
  • Updated fileformat version increased to 6
  • Added Jet/Pool fire object type and Radiation/RadiationDose variables
  • Fixed OpenGL transparency bug
  • Add clear->results option to comandline clear command
  • Updated ubl command to only clear buildings/meshes and threats in the text file
  • Major change to variables and results storage
  • Updated to work with Vista/Win7 64bit version
  • Added threat volume option to API 753 volume command
  • Added save file to desktop as a last resort before closing due to unhandled errors
  • Fixed error where any key press would focus the command line (only Space should)
  • Fixed bug with Bleve and PVB where P1<Patm would crash FACET3D
  • Updated threat grouping to allow multiple threats grouped/ungrouped at a time.
  • Added copy vapor cloud, copy congestion block links
  • Updated options GUI
  • Updated licensing to try all *.lic files before failing
  • Replaced NavBar control
  • Added user override of Volume command congested volume for API 753 zones
  • Add roof loads and max wall loads tables to buildings report
  • Fixed common dialog OK button

Version 9.6.5 Released on 6/5/2009

  • Added missing files to 9.6.1 package
    • Chemicaldatabase.xml
    • Microsoft.ExceptionMessageBox.dll

Version 9.6.1 Released on 6/1/2009

  • Added volume scaled FS/SL to CreateThreats report
  • Fixed bug with building % surface damage report
  • Added RowDataPrettyPrintHelper class
  • Updated rotate command will now work with buildings
  • Updated script error reporting, highlighting
  • Fixed DXF import of %%u and %%% text escapes
  • Updated shift click select made more accurate
  • Added LWPOLYLINE to dxf import
  • Added POLYFACE MESH to dxf import (Google SketchUp)
  • Added OpenGL graphics library
  • Added mesh and contours line width (OpenGL Only)
  • Added changed vapor cloud format to 5 points
  • Updated fileformat version increased to 5
  • Updated screen captures will now crop 2 pixels on each edge
  • Fixed buildings with angled roofs will not add extra wall section to roof
  • Updated unzip code to handler zip files with AES encryption
  • Updated screen capture class to work better on VISTA
  • Updated building clearing for pitched roofs
  • Added usage statistics reporting
  • Updated volume command to work with UCS selection boxes
  • Updated MEM 2D confinement check to error provider and 5x aspect ratio
  • Updated contour option Autocontour can now be used with log scale
  • Added right click menu to Command and Message areas
  • Fixed highlight rectangle command for surface selection
  • Fixed version number calculation method
  • Added drag drop of files onto 3D canvas for opening
  • Updated label rendering in OpenGL to use textures
  • Added RefreshLabelsEveryNSeconds option to options->rendering tab
  • Fixed bug with FastAnalysisMode and mesh damage calculations

Version 8.10.21 Released on 10/21/2008

  • Updated vapor clouds to be keyed on name instead of ID
  • Made saving safer using tmp and bak files similar to how AutoCAD works
  • Added label move with Alt key, label background fill
  • Added user coord system selection box option for congestion block and building placement
  • Convert file from old to new format will now properly convert materials calculate enabled property
  • Dxf import will now ignore null text or spaces only text objects
  • Fixed quick refine bug where dx less than edge length would lose surface
  • Fixed bug with GSA predefined legend strings and added ASTM predefined legends

Version 8.9.30 Released on 9/30/2008

  • Fixed bug where Enabled=False property of materials was not respected for meshes
  • Added comprehensive loads table to building detailed blast loads report

Version 8.9.15 Released on 9/15/2008

  • Added predefined building roof angle and direction fields
  • Congestion block threat grouping now has polygon option instead of projected circles
  • Import Z rotation transformations now allowed with arcs and text
  • Added dxf import support for ellipse (will be converted to lines)
  • Updated all forms to use Enter and Esc as default OK and Cancel button clicks
  • Updated bleve to include fragment fraction
  • Updated PVB to include real gasses
  • Added render building damage as BDL to options->buildings tab
  • Fixed bug with license dates for non-US regions
  • Updated reports to take advantage of per threat surface information
  • Added fast analysis mode option
  • Added per threat blast load storage to surfaces

Version 8.8.14 Released on 8/14/2008

  • Added Bleve and PVB threat types
  • Added Autorender option to ini file
  • Changed Toggle behavior on objects form
  • Fixed bug with elevated vc threat creation since convex hull optimization
  • Fixed bug where a custom flammable mixture with an inert would result in 0 lbv
  • Fixed bug where a custom flammable name collision would cause data loss
  • Script syntax highlighter updated to handle apostrophe inside of quotes
  •  %%u now removed from imported acad text
  • Added ignore option for PI validation errors
  • Added Edit button for custom flammables
  • Fixed bug with chemical names longer than 20 characters
  • Threat picking now gives more info on group threats
  • Added option to smart color VC threats similar to congestion blocks
  • Added option to fix camera target to ground plane (render tab)
  • Added Scripts to recent directory XINI file
  • Fixed unzipping bug associated with file dates
  • Added Flatten to Import DXF options
  • Updated all checked list boxes to multiselect list boxes

Version 8.6.3 Released on 6/3/2008

  • DXF export contours each on own layer, and as polylines instead of lines
  • DXF export will now respect enabled property of layers
  • Updated volume command to create API753 simple method contours
  • Added syntax highlighting to script editor
  • Fixed group threat UI form bug
  • Added script command, toolbar button
  • Changed mixture LFL calculation method to Le Chateliers rule
  • Added volume commandline command
  • Added marker, offset, and angle features to label object (fileversion=3)
  • Added chemical database for creating mixture properties
  • Added append commandline command for appending facet3d data from another file

Version 8.5.6 Released on 5/6/2008

  • Fixed orthogonal projection to work with on-screen select functions
  • Added hightlight rectangle commandline command
  • Added Open Threat button to create threats results summary dialog
  • Added camera.settarget toolbar button
  • VC create threats speed increase using convex hulls
  • VC create threats dialog updated with visibility options
  • Added Circle,Arc,Text objects
  • Drawbuilding command now uses P1/Size instead of P1/P2
  • Congestion blocks now use P1/Size instead of P1/P2 (fileversion=2)
  • Fixed surface move from mesh A to mesh B bug
  • GUI improvements, monospace text, obj. v3 pretty, parsing of vc and fuels

Version 8.4.3 Released on 4/3/2008

  • Added dplot PI import sort and round options
  • Fixed VC rendering bug
  • Fixed MEM create threats bug with controling SL
  • Added new backgroud image options - mult. textures supported
  • Added surface area to mesh summary report
  • Fixed surface damage % bug
  • Fixed BST CoOp calculations
  • Added shift click ignition source
  • Added object controls (CB color, VC transp., etc..)
  • Fixed pathfinding bugs

Version 8.3.24 Released on 3/24/2008

  • Added set mesh color and label size buttons on object form
  • Added zoom in and zoom out commands and toolbar buttons
  • Added BST.UseCoOpMethods to congestion block and threat dialogs
  • Added expansion factor to vapor cloud dialog
  • Added DrawBuilding(dbld) commandline command
  • Added objects listview column autosizing
  • Added ignitionsource commandline command
  • Added Ignition Source object type
  • Added VaporCloud.CreateThreats dialog
  • Changed groupedthreat DistanceTo to return min distance for all grouped threats
  • Added runsub 24 - distances from threats to buildings report
  • Updated threat input summary report
  • FileFormat increased to 1, added ThreatGrouping.OrganizationalOnly property
  • Added BDL and Roof P-I tables to end of Building DL and Loads report when AnalysisControls(1) selected
  • Added 'Set Label(s) Color' to Labels object menu
  • Added line contours to legend
  • Updated PI point inside polygon (stricter) by checking that all poly1 pts are also outside poly2
  • Removed clear visibility, use Enabled=False instead
  • Added gauges enabled property
  • Changed threats calculate property to enabled
  • Materials now show up in building listview
  • Meshes and buildings now have enabled property
  • Added Modify option to reloadxini (rex) command
  • Updated VaporCloud createthreats for grouped threats
  • Add dxf export dll for better dxf exporting
  • Commandline history feature (up arrow) more useful (tracks entire command sequence)
  • Added polygon delunay refinement (used internally for vapor cloud discretization)
  • Added vapor cloud commandline command with createthreats option
  • Added angle command
  • Updated move command to be able to explode buildings to meshes
  • Updated move command to work with buildings
  • Added autoupdate utility with download support
  • Updated object user interface navigation bar
  • Added vapor cloud dialogs
  • Surface manipulation commands (copy,refine) are now faster
  • Camera views now saved with file
  • Camera view managment code update
  • Fixed camera rotation at lat=90deg, zoom too close to target, smooth panning at lat=90
  • Added congestion blocks dialogs
  • Added new building reports
  • Added text engine 2d for labels
  • Converted all quantities to doubles
  • Added vector3 class wrapper with double precision
  • File versioning, file updating
  • Change buildings PI handling to match meshes
  • Removed legacy open code
  • Surfaces id by integer instead of strings
  • Updated materials code, specifically PI point inside test. Now uses polygons
  • Removed FACEDAP material types
  • Major refactor begin ...
  • Added AnalysisControls command and DL_MaxLoads report
  • Changed DHS vuln. model collapse % dih and doa as well as req. 2 columns
  • Predefined building damage levels report now uses legend text for DL
  • Changed AvgDia to inches on Threat form. Made VBR and AvgDia NUD Boxes
  • Shift click now reports threat, gauge, and congestion block objects
  • Added AllowLineSelection option on rendering tab
  • Added congestion block objects
  • Fixed dotproduct bug for parallel vectors

Version 4.0.2767 Released on 7/30/2007

  • Added DHS vulnerability model report for meshes
  • Using Log_Lin interp for BST and MEM curve interpolation
  • Using PHAST data for BST
  • Added ground contour color option and contour log scale option
  • Tweaked legend colorbar. Note using sunlight can skew contour colors!
  • Added legend numeric string format to options
  • Major rewrite of ground contour classes
  • Major rewrite of threat classes to include grouped threats
  • Updated Octane LBV to 52 cm/sec
  • Fileformat version increased to 4
  • Added custom flammable fuel definitions
  • Updated building risk occupancy input to allow non-integers
  • Added BST reduce energy calc form
  • Updated database with new (5/07) standard buildings/components
  • Added mesh color to mesh.color listview item
  • Added Threat input summary report
  • Updated drawbox command to order sides per Beast Methodology
  • Fixed MEM distance to threat line (display only) bug
  • Added BST energy reduction option via TNO rules
  • Added blast load select method for multiple concurrent threats
  • Added SaveInputsOnly option
  • Fileformat version increased to 3
  • Updated file save format, reduced file size ~50%
  • Updated VC quick calc normal to incident/reflected

Version 4.0.2631 Released on 3/16/2007

  • Removed NICMAC from machine fingerprint
  • Updated shift click hit XYPlane behaviour
  • Updated DXF import dialog
  • Fixed report visibility bug
  • Fixed activefile.hash bug for read only files
  • Added report keyboard shortcuts
  • Fixed UD threat contours bug for contour>max value
  • Updated F-N curve calculations

Version 4.0.2581 Released on 1/25/2007

  • Added recent files menu
  • Fixed bug in MEM - now shows ground impulse contours
  • Added drag-drop file onto commandbar from explorer to open
  • Updated DXF import/export color handling and ByLayer support
  • Beta version released on 12/7/2006
  • Tweaked PI cleanup code for CEDAW curves
  • Added line export to dxf file (contours if in pressure display)
  • Updated building centered siting analysis code
  • Updated DXF Import to ignore blocks
  • Updated menu and toolbar appearance
  • Added Zoom command with all, selection, and window options
  • Updated ActivateMaterials command to use a mesh selection dialog
  • Updated CleanPI codebase to better clean pi's from dplot
  • Added file compression option to FACET3D.ini file and Options dialog
  • Added *.flacs filetype to CFD imports
  • Added support to prevent overwriting a changed network file
  • Enhanced DXF import. Now handles circles and arcs
  • Enhanced Highlight mesh/building wildcard behavior
  • Added line contours to MapCFDLoads command
  • Added Impulse line contours
  • Added Building Damage Table report
  • Upgraded SetHazard command to include buildings
  • Added additional error checking for UserDefined curve assymptote order
  • Added Background Picture texture rendering
  • Added MapCFDLoads commandline command w/ isocontour support
  • Added mouse wheel support for zooming
  • Added better contour lines for elevated threats
  • Added delete duplicate mesh lines runsub command
  • Fixed black/white color bug, now better use of named colors
  • Added UserBlastLoads blast load mapping command
  • Added new Threat type - User Defined freefield pressure and impulse functions
  • Fixed bug in CorrPanels Facedap material type Edit subroutine
  • Added SaveAsDPlot button to material PI curve plots
  • Added Equation PI curve type to DB and code to create smooth point along curves
  • Added Beastv2 PI curves to DB and updated DTRA screening blds to freefield

Version 4.0.2252 Released on 3/02/2006

  • Updated license file codebase
  • Added SurfaceErrorCheck and SurfaceErrorFix commandline commands
  • Updated surface refine algorithms
  • Added GarbageCollect free memory command
  • Added Projection and FillMode render options
  • Converted to .NET 2.0 and related MDX assemblies
  • Added Highlight Toggle option
  • Updated mesh properties report to include %Area Hazard
  • Improved REDRAW, HE, and BST load calculation engines speed
  • Added color check surface normals render option
  • Added selected surface normals render option
  • Added movie path spline, set camera button, snap to waypoint, angle criteria, ...
  • Added more functionality for camera command
  • Added SetMeshColor commandline command
  • Added threat copy, material copy, and predefined bld copy
  • Added MEM rounded corner contours

Version 4.0.2039 Released on 8/01/2005

  • Added link (F1) to online help file
  • Added toolbar buttons for movie setup and reporting
  • Added Mesh and Building list properties reports
  • Added EQE facility siting codebase
  • Added toggle all switch to import dialog
  • Added rotation angle feature to MEM and BST vaporclouds
  • Added clearing effects for meshes and predefined buildings
  • Updated hardlock to latest usb HaspHL codebase
  • Updated screencapture to be faster, auto-crop, and use exact display size
  • Added AVI file movie creation
  • Added automatic movie waypoint creation through ghostview
  • Added command alias values to xini file
  • Changed commandline codebase and added new functionality
  • Added skybox background option
  • Added show camera target to render options
  • Added GhostView flythrough mode

Version 4.0.1915 Released on 3/30/2005

  • Changed license model to include multiple hardware checks
  • Added DijkstraConeAngle to XINI file
  • Added lineload table threat report mode
  • Forced all mesh, building, threat, material names to be lowercase
  • Fixed display bug for hazard contours after file open
  • Added better import surface error checking

Version 4.0.1875 Released on 2/18/2005

  • Added camera ToFile & FromFile hyperlinks on camera form
  • Added pressure contour lines to BST threat
  • Added DPlot import automatic PI cleanup switch to XINI file
  • Added pirecalc commandline command

Version 4.0.1830 Released on 1/4/2005

  • Added commandline history queue (press up arrow for past commands)
  • Added reloadxini commandline command
  • Added ScreenCaptureTweak section to xini file
  • Added report export to clipboard and file capabilities
  • Fixed numeric text box so a neg. sign is allowed if all text is selected
  • Reworked options form
  • Added user defined legend text
  • Updated tab order on Threat form
  • Added ActivateMaterials, Area, Sethazard command line commands

Version 4.0.1745 Released on 10/11/2004

  • Added PI plot screen capture
  • Added Baker-Strehlow-Tang (BST) VCE threat type
  • Added import DPLOT file from materials form

Version 4.0.1689 Released on 8/17/2004

  • Added material calc toggle and MaterialCalc column to layers dialog
  • Increased import dxf speed and added feedback

Version 4.0.1657 Released on 7/15/2004

  • Added single threat octahedron platonic solid
  • Added legend size and placement controls
  • Upgraded plot control
  • Added user defined hazard level coloring
  • Added screening level building PI calculation method
  • Added drawbox command line command
  • Added contour scale factor for non-linear contour colors
  • Added MEM2 override energy and severity level option
  • Added Visibility combobox to implement transparency
  • Added Calculate option to materials
  • Upgraded command line behavior
  • Added predefined buildings
  • Changed general object architecture to layers, meshes, and buildings
  • Added a materials library
  • Added a threat render scale factor
  • Fixed minor MEM2 severity level bug (single now instead of integer)
  • Optimized blast load calculations CRAlpha and IRAlpha subroutines
  • Changed display text font and format
  • Added ground pressure contours
  • Fixed minor LineObjects render bug
  • Added options button on main toolbar
  • Changed FrmMain layout
  • Added Dijkstra path finding
  • Fixed minor FileIO bug when reading files that are ReadOnly
  • Added compilation constant IsViewer

Version 3.0.1397 Released on 10/29/2003

  • Implemented pause render during file dialog selection
  • Added error checking for decending impulse

Version 3.0.1396 Released on 10/28/2003

  • Added ErrorProvider for material validation
  • Added new graphing component for materials
  • Fixed bug in Render code for high surface counts
  • Added PickLines code for shift-clicking
  • Updated KillGroup command
  • Added MoveGroupLines command
  • Added LineCollection class
  • Added new DXF Import dialog

Version 3.0.1370 Released on 10/2/2003

  • Added save to xml and open xml files capability
  • Added new menu item View which contains pre-post options

Version 3.0.1357 Released on 9/19/2003

  • Added color change dependent on background color for camera coordinates
  • Added ListBuilder capability
  • Toggled sort property to on for various list and combo boxes
  • Forced Sub UpdateReport on form activation
  • Added crypto class and updated register form
  • Updated FileIO->RetrieveProgramState sub to give feedback on backward compatibility issues
  • Added various shortcuts to menu items
  • Added flythrough movie creation capabilities
  • Updated registration form and overall licensing model
  • Added commandline command Toggle
  • Added FolderDialog for movie files save path

Version 3.0.1311 Released on 8/04/2003

  • Added automatic contour legend option
  • Added code to prompt if options class has changed
  • Added a save dialog to new and open menu commands

Version 3.0.1278 Released on 7/02/2003

  • Updated DialogForm showintaskbar and readonly properties
  • Added VersionHistory to commandline commands
  • Allows spaces between brackets on command line commands
  • Added a save dialog upon closing of program
  • Added escape key closing on DialogForm forms
  • Added FACEDAP corrugated panels material
  • Added Equivalent Loading reporting option
  • Changed reporting form to real time updating

Version 3.0.1266 Released on 6/20/2003

  • First recorded release. Actual development started in mid 2002.
Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox